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About This Quick Start Guide 
This Quick Start guide will walk you through RAGE WebDesign and give you an overview of its basic and some of its more powerful 
features. It covers everything from opening and saving documents to actually working with different web languages. It will teach you 
how to customize RAGE WebDesign to suite your needs and how to get your web site and up and running.  

You can’t read a book without knowing how to read and likewise you cannot build a web site without knowing the basics of HTML. 
RAGE WebDesign does require basic knowledge of HTML. But don’t worry this is not as hard as it may sound. HTML is the easiest 
and most basic web language to learn and the following section will introduce you to HTML and get you on your way. RAGE 
WebDesign’s integrated HTML reference, built in page preview, attribute editor and html wizards will help you master HTML as 
quickly as possible. Before you get concerned with having to learn HTML or not having enough time, it is important to know the 
basics of HTML for 3 reasons; 

1. You will be able to create the most compatible and fastest loading web pages. Slow loading web pages or pages that are 
incompatible with certain web browsers are created by programs that generate all the HTML code for you. These editors are 
called WYSIWYG (pronounced wizi – wig; What You See Is What You Get) HTML Editors. However, in reality they 
should be called WYSIPNWYGG (What You See Is Probably Not What You’re Going to Get). The reason is that they 
cannot predict exactly what you want and they will end up producing extraneous code that takes longer to load and that 
doesn’t look the same in all web browsers. Actually knowing how to write the source code for web pages gives you more 
control and more flexibility. Think about this the next time you visit a slow loading or incompatible web page. 

2. Knowing the basics of HTML lets you easily make changes to your site in the future. If all web browsers can not even 
interpret your web page, how are other visual HTML generators going to be able to, or even you or  a professional web 
developer? Taking a few minutes now, saves you from lots of frustration in the future. 

3. You don’t have to be an HTML master. You just have to know enough to get by. RAGE WebDesign fills in the rest. 
Certain parts of HTML can be complicated like HTML Tables and Image Maps. RAGE WebDesign takes care of all of this 
for you with its built in wizards but doesn’t produce any unneeded code since no guessing is involved. You control the output 
and you control your web page.  

An Introduction To HTML 

HTML (Hypertext Markup Language) is the language used to create and design web pages. HTML files are simply text documents 
containing instructions telling the web browser how to format your web page. An HTML document contains HTML tags (instructions 
for the web browser) which are in the form of: 
<TAGNAME ATTRIBUTE="VALUE"> 
 
Where ‘TAGNAME’ is the name of the tag (or instruction) and ‘ATTRIBUTE’ is additional information needed by the web browser 
to interpret the tag (instruction). For example the following code places an image on your web page using the ‘img’ TAG and the ‘src’ 
ATTRIBUTE to point to the image file on your web server. 
<img src="images/picture.jpg"> 
 
In some cases an HTML tag may need an ending tag which are simply written as: 
</TAGNAME> 
 
 For example, to tell your browser to make some text bold you would write; 
 <B>...bold text...</B>. 
  
 The most basic web page can be written as follows; 
<HTML> 
        <HEAD> 
        <TITLE>Web Page Title (Appears in the Top Menu Bar)</TITLE> 
        </HEAD> 
        <BODY> 
...anything that should be displayed in the browser window goes here... 
        </BODY> 
</HTML> 
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Any text that is written between the <BODY> and </BODY> tags will show up on your web site unless it is incased in (< and >). 
HTML is not case sensitive so <BODY> and <body> are seen as the same instructions to a web browser. Some users find it easier to 
read HTML pages when the tags are written in uppercase, however it is now a common practice to keep all tags in lowercase to 
maintain compatibility with different kinds of devices. 
 
Fortunately, RAGE WebDesign allows you to convert tags to lowercase or uppercase simply by going to HTML Tools->Change Tag 
Case. 
 
Line Breaks In HTML Pages  
As noted above, all text placed with the the <BODY> and </BODY> tags, excluding text incased in (< and >), will show up in your 
web browser. This, however, is not entirely true when working with line breaks. Line Breaks are ignored by browsers and this can 
usually cause confusion for first time web developers. 
 
There are two ways to insert line breaks in your document. 
 
You can use the <BR> tag which will create a single line breaks. 
 
 These lines of text appear on 
<BR> different lines in your browser 
 
 or the; 
<P>The text within the P tags are displayed in a separate paragraph.</P>  
 
tag to create a new paragraph which will insert two line breaks around the surrounded text. 
 
(note: </P> is not required when creating a paragraph, but is highly recommended. It is a good idea to get into the habit of closing all tags that have 
a required or optional closing tag including <P>, <LI> etc... To learn why, read the section on XHTML in this user manual). 
 
Linking to Other Pages  
If you would like users to be able to access another web site, or another page on your site, you can use a hyper link to accomplish 
this. To create a hyperlink either use the drag and drop tools palette in RAGE WebDesign or use the Insert menu and select 'Link...'. 
 
Type the address that you would like the link to take the user to in the ‘URL’ field. Type the text that should be displayed in the 
browser in the 'Text' field. Click the 'Insert' button and the text will be inserted into your document. 
  
(note: You can leave the Target field blank. This attribute is usually used with frames or to control whether or not the link is opened in a new 
window. You can press the Help button to learn more about it but in this example you can ignore it.) 
 
Notice the code that is entered; 
 <a href="http://www.ragesw.com">Rage Software</a>  
 
As you can see the <a> TAG is used to create a link to another web site and the 'href' attribute is used to specify the location of the 
web site. The text to be displayed in the browser is between the <a> and </a> tags. It is a good idea to study the code that is 
generated by RAGE WebDesign's wizards so that you are able to more quickly become familiar with the different tags and attributes in 
the HTML language. 
  
Online Resources  
If you would like to continue to learn more about HTML and create more complex and  more compelling web sites you can visit the 
following web sites; 
http://www.w3.org, http://www.HTMLHelp.com, http://www.w3schools.com
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From Installation to Introduction 

The first thing you should do is place RAGE WebDesign in your Applications folder. Drag the entire RAGE WebDesign folder from 
the Disk Image and drop it into your Applications folder. Next open the RAGE WebDesign folder and launch the RAGE WebDesign 
application by double clicking it.  

 

The first thing that will happen when you launch 
RAGE WebDesign is you will see the ‘New 
Document’ window as shown to the left. From here 
you can enter your web page title, your name as the 
author of your web page as well as appearance 
options and Java Scripts if you have any. The ‘Meta 
Data’ field will let you enter your web site description 
and keywords that will be recognized by search 
engines. The ‘Examples’ section will allow you to 
start a new document based on the example you have 
selected. There are also template files you can use to 
base your web page on in the ‘Examples’ tab. If you 
do not wish to enter any information, you can start 
with a blank document by pressing the 'Blank 
Document' button.  

After you have entered all your information press the 
'Create' button to create your web page. A new 
document window will appear which will look like the 
picture below. You can start developing your web site 
by typing html code in-between the <body> and 
</body> tags; Figure 1: Use the New Document window to set the default 

information for your web page. Or use the 'Examples' section to 
base your web page on an example or template. 
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You do not have to just type code, you can also drag tools from the ‘Items’ window on the left hand side or use the ‘Insert’ menu at 
the top of your screen to access all of RAGE 
WebDesign's built in wizards. 

The wizards that appear allow you to enter 
information about the tag without you having to 
know the actual HTML syntax. They also have a 
reference for the specific tag you are trying to use 
which can be accessed by pressing the '?' button in 
the lower left hand corner. 

RAGE WebDesign also contains many other 
features to help you write your HTML code. The 
attribute editor will list all the attributes for a 
specific tag as well as access the HTML reference 
if you are unsure what a specific tag or attribute 
does. To use the attribute editor, simply click 
within an html tag in RAGE WebDesign's editor to 
have its attributes listed. If the attribute editor is 
not shown, you can open it by going to the 
‘Windows’ menu and selecting ‘Show Attribute 
Editor’. 

RAGE WebDesign's attribute editor lets you easily select colors using Apple's Color picker and automatically generates the HTML 
color code for you as you can see with the bgcolor attribute. It also lists all possible values for certain attributes such as the align 
attributes which only accepts 3 specific values. Other attributes have the 'More Text' button which opens a new window so you can 
easily add lengthy text to certain attributes instead of typing it in the ‘Value’ cell of the attributes list. The little arrows in the upper 
right hand corner of the attribute editor let you define the case of the attributes and their values. You have the ability to enter the 
attributes or their values as lowercase, uppercase or default. 
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Helpful Tips for Working with RAGE WebDesign 

Here are some tips that will show you some of the features of RAGE WebDesign that can help with coding; 

1. RAGE WebDesign's text editor is very customizable. You can show line numbers to quickly and easily find errors in your 
document, you can Auto Indent text, which is enabled by default, so that each new line starts at the exact same amount of 
tabs as the previous line, you can even adjust the soft wrapping options (which wraps the text once it has reached a certain 
point, or the end of the window so that you do not have use the horizontal scrollbar) to hard wrap the text (which only 
creates a new line when the return key is pressed). Selecting ‘Document Settings…’ will let you change all of the editor 
settings at once. 

2. You can easily switch between all opened documents by going to the Windows menu and selecting 'Next Window' or use the 
keyboard shortcut to do this quickly (Command-`) 

3. Creating a link in RAGE WebDesign that allows visitors who visit your site to get to other pages is easy. Simply drag and 
drop the link wizard from the ‘Items’ window or go to the Insert menu and select 'Link...'. However, RAGE WebDesign 
makes things even more convenient for you by filling in the Text portion of the Link wizard with the currently selected text. 
So if you want to link to a certain document and place the link around some text that is already typed in your document, 
highlight it and open the ‘Link’ wizard from the 'Insert' menu. 

4. Drag and drop image files onto RAGE WebDesign's editor wherever you want to place them in your code. RAGE 
WebDesign's ‘Image’ wizard will open and fill in the ‘src’ attribute and get the dimensions of the image for you. If you drop 
any other kind of file besides an image file, RAGE WebDesign's ‘Link’ wizard will open up with the ‘href’ attribute pointing 
to the file. 

5. You can quickly open any file that is linked in your document. This means normal links such as '<a href=', style sheets linked 
to your document by the LINK tag, scripts linked to your document from the SCRIPT tag, any frames, image map links or 
even RAGE WebDesign Includes. Just click within an HTML tag that links to another document and either go to File->'Open 
Linked Document' or control-click and select 'Open Linked Document'. Whether you use an absolute path (file:///...) or a 
relative path (a path that points to the linked file relative to the current document), RAGE WebDesign will search your hard 
drive and open it in RAGE WebDesign for you. 

6. If you are only working on a certain portion of a document or don't want to be bothered with certain code you can condense 
(or collapse) it by selecting the text and going to the Text menu and selecting ‘Condense Selected Text’ (COMMAND-E) 

7. Don't forget about the plug-ins available to you. There are a bunch of Cascading Style Sheet plug-ins and JavaScript plug-ins 
included with the RAGE WebDesign Download. Plug-ins can be accessed just like the wizards. Notice the Popup menu at the 
bottom of the ‘Items’ window. This popup menu lets you select the different types of plug-ins. Just drag the plug-ins into 
your document like you would any other wizard. You can even download more plug-ins from the RAGE WebDesign 
Resources Web Site at http://www.ragesw.com/community/ for free. 

8. Language extensions are another powerful feature of RAGE WebDesign. As you start to expand into more web languages 
and build more complex web sites, Language Extensions will really come in handy. Built in are Cascading Style Sheet 
Language Extensions along with access to a help References, HTML Language Extension, JavaScript Language Extension 
and an ASP Language Extension. More Language Extensions can be downloaded from the RAGE WebDesign Resources 
Web Site at http://www.ragesw.com/community/ for free. 

9. Find more helpful tips and tricks by going to the application menu in the upper left hand corner on Mac OS X or the Apple 
menu in Mac OS 9 and select 'Show Random Tip...'. 
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See How Your Page Looks as You Develop 

During web site development it is often the case that you would want to see how your web site looks in a web browser. RAGE 
WebDesign provides the ability to not only preview your web pages in an unlimited number of web browsers, but it also allows you to 
see exactly what your web page will look like with its built in page preview feature.  

Before being able to preview your documents you must add browsers to the ‘Open In’ Applications list. Open the preferences window 
and click the 'Internet' Tab. Then click the 'Add' button to add web browsers to the list. Save your preferences and you are now ready 
to start previewing your documents.  

 

You can add any kind of application to this list and RAGE WebDesign will open the current document in that Application when it is 
selected. So for example, you can add your favorite CSS editor, open the current document in the CSS Editor, edit your CSS code and 
when you return to RAGE WebDesign, your document will be updated to reflect those changes. You can also add things such as link 

checkers, HTML validators or even a WYSIWYG HTML editor to edit complex HTML code in.  

While working with your web site you may click the 'Preview' button or go to ‘File’ 
menu->'Open In' and select the web browser you want to preview your page in. If 
you select 'In RAGE WebDesign...' your document will be previewed with RAGE 
WebDesign's preview features. In Mac OS X 10.3 or later you can have side-by-side 
previews. In OS 10.1 and OS 9, RAGE WebDesign will switch to preview mode 
within the main editor window.  

It is recommended that you save your document before previewing so that images 
and other code using relative paths show up correctly. RAGE WebDesign can 
automatically save your document before previewing by setting this option in the 
'Application' tab in the Preferences.  

RAGE WebDesign can even preview PHP code. You must have Personal Web Sharing enabled as well as PHP enabled in Mac OS X 
10.3. The User Manual provides step by step instructions on how to do this.  
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Customizing the Editor and Using Document Modes 

RAGE WebDesign's text editor provides many different features and settings to help you code faster, produce more efficient code and 
locate errors quickly. Syntax coloring helps you quickly locates specific tags, function declarations, attributes or even errors in your 
document such as missing quotes. Line numbers provide an easy way to track down errors especially when working with PHP 
documents. Auto indent options allow you to write cleaner code without a lot of effort on your part and Smart Auto Indenting takes 
this one step further. There are many more options that you can explore and test on your own. They are described in more detail 
below. 

Before going any further it is important to know how RAGE WebDesign works. RAGE WebDesign contains a set of built in 
document modes which include regular Text, HTML, XHTML, PHP, CSS, JavaScript, ASP, XML, and VBScript. These document 
modes contain default settings that make working with the respected language more convenient. For example, each document mode 
has it's own Syntax file which defines how text is colored in your document so you can easily spot any potential coding errors. Other 
settings, like Smart Indenting Braces is enabled for PHP documents so that when you create a function like the following; 
 

 
function "Hello_World" { 
 
   print "Hello World" 
 
}  
 
it is properly indented for you removing the need for those extra keystrokes each time. These document modes are basically presets for 
each kind of language and can be completely customized to suite your coding behavior. The RAGE WebDesign Tech Notes in the 
User Manual explains in detail how to create custom Syntax Files for RAGE WebDesign. 

Now lets say you open one of your pages in RAGE WebDesign. RAGE WebDesign will automatically set the document mode, and 
apply all of the settings you have selected for that mode. It does this by reading the file extension and finding the document mode that 
corresponds to that extension. For example, a file with the extension ‘.html’ will open in the HTML mode. Likewise, a file with the 
extension ‘.php’ will open up in PHP mode. The way RAGE WebDesign matches document modes to extensions can be modified in 

the 'Editor Modes' tab of the Preferences. As well 
from this tab, you can customize all other settings for 
the selected Document mode, as shown below. Of 
course you can switch between document modes for 
already opened documents from the ‘Pencil’ icon at 
the top of the Editor window.  

• File Extensions: Set the file extensions, 
separated by a semicolon (;), that should be 
opened under the selected Document Mode. 
For example, HTML files are recognized by 
files with the extensions ‘html’, ‘shtml’, 
‘htm’ and ‘shtml’ in the picture to the left. 

• Default Extension: The default extension is 
the extension that an new document will use 
when using the selected Document Mode 
when you save a file. In this picture above 
no default extension is used but you can type 
‘.html’ for all files saved under the HTML 
Document Mode. The default extension only 
applies to the ‘Save As’ dialog box and no 
file extension is appended when opening an 
existing document. Note: In Mac OS X, if a 
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default extension is specified, it cannot be changed in the ‘Save As’ dialog. This is the way Apple designed the Save As dialogs in Mac OS 
X and is why the default extension for all document modes is not set. 

• Syntax File: Lets you select the syntax file or add a new one to your ‘Syntax Files’ Folder located in the ‘Support Folder’ in 
the same folder as the RAGE WebDesign Application. Creating Syntax files is very easy and is discussed more in the ‘Tech 
Notes’ section of the User Manual. When you add new syntax files they are moved to your Syntax Files folder. 

• Wrap Text: Enable or disable soft wrapped text. Soft wrapped text can be wrapped at the end of the window or at a certain 
pixel length. The different between soft wrapped and hard wrapped text is with soft wrapped text the text is wrapped to a new 
line when it hits a certain spot (the end of the window or the specified pixel length), while hard wrapped text only wraps 
when you create a new line break (i.e. pressing return). 

• Enable Tabs: If you want to be able to use tabs as well as specify the tab width in pixels, enable this option. 
• Auto Indent: This option, when checked, will start new lines containing the same amount of tabs and spaces as the line 

above it up to the first real character. For example if the current line is tabbed 3 spaces over, the next line, after pressing 
return, will start at 3 tabs over. This is helpful in keeping readable code while preventing you from having to type those extra 
keystrokes each time. 

• Smart Indenting Braces: This option, depicted above with the PHP function example, will auto indent text when the current 
line contains a '{' character and detab when you close the function by entering the '}' character. 

• Use XML Syntax Rules: This option will adhere to XML syntax rules, such as entering text in lower case, not leaving out 
quotes etc... It is used specifically for the XHTML and XML Document Modes. 

• Show Line Numbers: This option shows the line numbers in your document along the left hand side so you can easily see 
which line you are typing in. 

• Show Cursor Position This option will show the line number and the location of the insertion point in the current line in the 
bottom left hand corner of each document window. 

• Match Opening Parenthesis: When you close a parenthesis, RAGE WebDesign can highlight the opening parenthesis or 
flash the menu bar if it can't find one so you can easily spot a missing parenthesis in your code. 

• Show Invisible Characters: Select this option if you want to see where any spaces or returns are. This is helpful to spot 
double spaces that should be removed (note: cannot currently be enabled along with the Use Tabs option). 

• Auto-complete: As you type, RAGE WebDesign will display a list of keywords which gets filtered each time you type a new 
character. Auto-complete works when typing HTML Tags, attributes and even attribute values. The Auto-Complete Site Files 
will suggest file paths for files in your site when editing href and src attribute values. 

RAGE WebDesign lets you easily switch between Document Modes right 
from within the Editor. So for example if you are working with a document 
that was recognized as a PHP file but contains mostly HTML code, you can 
switch to the HTML Document Mode by using the Document Modes menu in 
the editor window as shown to the left 

 

If you want to quickly change a single setting, or even a bunch of settings for 
RAGE WebDesign's editor for the current document you can open the 

Document Settings dialog from under the Edit Menu. From here you have 
access to all the settings that can be customized for the current document.
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Every Way to Create New Documents 
RAGE WebDesign lets you create documents a number of ways. If you 
want to learn about opening existing documents you can skip to the next 
section. Otherwise, you can learn about the various ways that RAGE 
WebDesign provides to create new documents as well as the starting points 
which limits the amount of code you need to write. 

New HTML Files  
RAGE WebDesign provides a built in ‘New HTML Document’ wizard that 
you can access by going to the File menu and selecting 'New Web Page...' 
The New Document window is discussed above in detail in the 
‘Introduction’ section. 

 

 

New Frameset Documents  

Like the ‘New HTML Document’ wizard, the ‘New Frameset’ wizard lets you 
create a new frameset document without typing any code. To access the new 
‘Frameset’ wizard go to the File menu and select 'New Frameset...' 

Use the ‘Frameset’ wizard to create a web page with frames without having 
to write any code. After you click the 'OK' button RAGE WebDesign will 
generate the necessary code in a new document window for your frameset 
page. 

New With Stationery  

You may already be familiar with stationery files since many applications use 
them. If not, stationery files are similar to templates. They provide a starting 
point, or a skeleton of a certain kind of document. You access stationery files 
from the File menu. Stationery files are located in the folder labeled 
'Stationery Files' in the same folder as the RAGE WebDesign application. 
You can place your own files in that folder to use them as stationery files. 

When you open a stationery file in RAGE WebDesign it is opened as an unsaved document as if you created a new document 
containing that text. You don't save the document back to the original file but to a different location so that the stationery file can be 
used over and over again. 

New Blank Document  
RAGE WebDesign can create a new blank document so that you can start from scratch. Just select 'New Blank Document...' from the 
File menu. 
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Opening Documents and Editing them in RAGE WebDesign  

RAGE WebDesign lets you open any kind of HTML document or 
other web page written in any other HTML editor. It doesn't matter 
where a web page is created since they are just text documents giving 
the web browser instructions on how to load them. Any document 
created in another HTML editor can be opened in RAGE WebDesign 
and any document created in RAGE WebDesign can be opened in any 
other HTML editor.  

RAGE WebDesign provides a variety of methods to open documents. 
You can open local documents from your computer, you can open 
document from your FTP server and save them back all from within 
RAGE WebDesign or you can download a web page right off the web 
by typing in a url (although you will not be able to save it directly back 
unless you have the login information for the web server).  

Opening documents locally 
RAGE WebDesign will let you open document locally like any other 
word processing application. Simply go to the File menu and select 'Open...'. From here you will be able to open any document written 
in a language supported by RAGE WebDesign. However, if you want to open a document written in a language not directly supported 
in RAGE WebDesign (although still edit-able in RAGE WebDesign) use the 'Open Any...' menu item which lets you open any kind of 
file. 

Opening a document from an FTP server 
RAGE WebDesign allows you to open 
documents directly from your FTP server and 
save them back. Go to the ‘File’ menu and 
select 'Open from FTP Server...' The window 
to the right will appear. Enter your login 
information and press the 'Connect' button. 
Your files will be listed for you and you can 
double click them to open one in RAGE 
WebDesign. Saving them will save them right 
back to your FTP server for you. The Default 
Directory' field allows you to specify the 
directory that will be listed when the FTP 
Browser connects to your server. You can 
leave this field blank if you want it to connect 
to the root directory. 

 

Opening documents from a web address (URL) 
RAGE WebDesign lets you download pages right off the web by 
typing in any URL. It will download the source code for that page 
so you can play around with it, use at as a template or learn from 
it. To download a page by typing in a web address go to the ‘File’ 
menu and select 'Open From URL...'. The following dialog will 
open allowing you to enter a web address and download the source 
code. However, you cannot save a web page downloaded from a 
specific URL unless you have the login information for the web 
page's FTP server. See below for more details on saving web pages 
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and getting them online through the built in FTP Browser. 

 

Opening Recent Documents  

RAGE WebDesign keeps track of all the documents that you open so you can quickly open recent documents that have been 
previously opened in RAGE WebDesign. By default, RAGE WebDesign will remember the last 10 opened documents but you can 
change the number by going to the 'Application' tab of the Preferences. 

You can access the most recently opened files from the 'File' menu as shown the File menu picture above. The recent menu will also 
show files that have been opened from your FTP server through RAGE WebDesign's built in FTP Browser. When you select a 
recently opened file that was downloaded from your FTP server, a dialog will appear asking for your FTP server password before 
downloading. 

 

When you try to open a recently opened document that came from an 
FTP server, the following login dialog appears. Enter your server 

password and click the OK button to download the file. You can then save 
it directly back to your FTP server when you go to ‘File’->’Save’ 

(COMMAND-S) 

 



 RAGE WebDesign Quick Start  14 of 18 

Saving Documents in RAGE WebDesign 

RAGE WebDesign lets you save files just as easily as any other text editor or word 
processing application. The familiar COMMAND-S (‘File’ menu->’Save’) saves a 
modified document and SHIFT-COMMAND-S allows you to save the document in 
another location by doing a 'Save As...'. 

RAGE WebDesign lets you save documents just like any other word processing 
application. The save menu item becomes enabled once you make any modification 
to your document. RAGE WebDesign also allows you to save all opened documents 
at once.  

When you have opened a web page from a remote location such as a FTP server 
using the built in FTP Browser, RAGE WebDesign will automatically save the 
document back to your server when you select the ‘Save’ command from the ‘File’ 
menu (COMMAND-S). A status window will open with your FTP login 
information that RAGE WebDesign stored when you first downloaded the page as 
shown below. 

 

 

Save to FTP...  
RAGE WebDesign lets you save files directly to your FTP server. Just select 'Save To FTP...' from the File menu to open the FTP 
Browser then enter your login information, navigate to the location you want to save your file in and press the 'Upload Page' button as 
shown below. 

Once you save the file to your FTP server, RAGE WebDesign will continue to upload it back automatically each time you save your 
file regularly in RAGE WebDesign. It will also update the local copy if it was previously saved on your hard drive. 

Backing Up Files  
RAGE WebDesign can automatically back up your files on save or you can manually backup your files whenever you feel it is 
necessary. 

• Automatically Backup Documents 

RAGE WebDesign will back up your documents automatically each time you save if you set it to do so. Setting up RAGE 
WebDesign to backup your files automatically is simple. Just open the Preferences and select the 'Documents' tab. Then 
check the 'Create Backup on Save' option and select your backup folder. By default a ‘Backup’ folder is created in the same 
folder as the RAGE WebDesign application if you do not select one. 

• Manually Backup Documents 

You can back up the current document manually whenever you feel you need to. Just go to the ‘File’ menu and select ‘Back 
up Document’->’Make Backup Now’. RAGE WebDesign will make a backup of the current document in your Backup 
folder. If you have not selected one in the Preferences under the ‘Documents’ tab, RAGE WebDesign will create one for you 
in the same folder as the RAGE WebDesign application. 
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Custom Save Options  
RAGE WebDesign lets you set different options when saving files as you can see from the saving preferences options below. To 
modify the saving options select the 'Document' tab from the Preferences window. The following options, depicted below, allow you 
to do the following; 

Save files depending on the operating system you will be using them on. Saving as UNIX will allow virtually all editors to be able to 
read your document and allow your page to be compatible with virtually all web servers. You can save files as any kind of document 

by entering their 4-character creator code. The popup-menu provides some common creator codes that you may want to save your file 
as. When you double-click the document in the Finder it will be opened in the application that you have specified. 

• RAGE WebDesign lets you set the type of line breaks that your document will use. Since RAGE WebDesign will recognize 
and convert any line breaks in a document you open, you don't have worry about what you save your line breaks as if you 
were just using RAGE WebDesign and no other editor application, although most other applications will recognize and 
correctly display any document with any line breaks. 

Each operating system, Windows, UNIX/Linux, and Macintosh, use different characters when creating line breaks. 
Macintosh line breaks consist of the character with an ASCII value of 13 and this option should be used if you are going to be 
sending or using the file only on a Macintosh. UNIX line breaks consist of the character with an ASCII value of 10. This 
option, set by default on Mac OS X, should be used if you plan on sending your file to someone on a UNIX system or if you 
plan on uploading your web page to a UNIX server. Lastly Windows line breaks uses two characters consisting of the ASCII 
value of 10 and 13. If you plan on sending your file to a Windows machine or are uploading to a Windows server, you should 
use this option. By default, documents are saved as UNIX files and this should not cause a problem for you unless you are 
using another application that does not support UNIX line breaks. It is a good idea to keep this option set as most servers 
expect this type of line break. 

RAGE WebDesign can keep track of the document's line breaks when you open a document and save it back using the same 
line breaks by selecting this option from the line breaks menu. 

• RAGE WebDesign lets you control the type of file that a document you save is saved as. If you set it to anything other than 
RAGE WebDesign, your document will be opened in that application when it is double-clicked in the Finder. You can still 
open it in RAGE WebDesign by using the Open Dialog (‘File’ menu-> ‘Open...’) or drag and dropping the file on RAGE 
WebDesign's icon in the Finder. You have to type in the 4-character document code or select one of the applications from the 
popup menu beside the field. 

Note: If you don't have the selected application installed on your computer, the Finder may report an error when you double-
click it to open it in the Finder. 

If you want your documents to always retain their original document type when you open than save the document in RAGE 
WebDesign, just check the 'Keep original creator code' check box.  
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Managing Your Web Sites With RAGE WebDesign's Site Manager 

RAGE WebDesign provides a powerful Site Manager to help you organize your web site and conveniently create, edit and maintain 
entire web sites locally until they are ready to go online. In which case, RAGE WebDesign handles all this for you by uploading your 
entire web site, or the most recently modified documents, to your FTP server. 

This tutorial will walk you through the steps of creating a new web site from scratch using RAGE WebDesign's Site Manager and 
explain what each option allows you to do. 

To start, select 'New Web Site...' from the File menu. The following dialog 
appears allowing you to create a ‘New Web Site’, Open an existing one or 
Import a Folder containing your web site files. When you create or Import a 
web site folder, RAGE WebDesign creates a '.site file in the same folder as 
your web site files. This is your Web Site Project file and is what you would 
select if you were importing a web site. It contains references to your web site 
folder and other information RAGE WebDesign uses to manage your web 
sites. 

Create web sites in RAGE WebDesign using RAGE WebDesign's Site 
Manager. Go to ‘File’ menu ->’New Web Site’ to create a new web site. 

When you create, open, or import a web site it will be added to your Recent 
Web Sites list in the  upper right hand corner of the Site Manager. You can 
quickly open recent web sites by selecting them from this list. 

Your next step to creating a new web site is to press the ‘Select’ button in order to select the location on your hard drive that you want 
RAGE WebDesign to store your web site files in. Once you have selected the location, RAGE WebDesign will prompt you for the 
name of your web site and create the necessary files for you. RAGE WebDesign creates your Web Site folder with an ‘images’ folder, 
so you have a central location to place all your image files, and an ‘index.html’ file which will be your homepage as shown in the 
screen shot below. 

Use RAGE WebDesign's site manager to manage your 
entire web site. Double-click a web page to open it in 
RAGE WebDesign, or double-click a media file to have 
the option of opening the file in any selected 
application. 

Notice the date in the upper left hand corner of the Site 
Manager. This date shows you the last time your web 
site was uploaded to your FTP server through RAGE 
WebDesign. Or, if it hasn't been uploaded yet, it will 
show a date in the distant path. Double-clicking any file 
will open it in RAGE WebDesign, or if it is not 
supported in RAGE WebDesign, you will have the 
option of opening it in any application you select. 

RAGE WebDesign makes it easy to create new sub folders or new pages. Just click the +/- buttons in either side of the window 
according to the screenshot above. A new folder or page is created and allows you to enter the name. You can rename any file or 
folder by selecting it and pressing the return key. 
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Previewing your Web Site with Mac OS X's built in Server 

In Mac OS X, you are able to set up your own personal web sharing account which lets you share your web site with other people 
around the world who can connect to your computer and view your web site while you are developing it. Basically, your Mac becomes 
your own personal server where users are able to connect, based on the permissions you give them, and view your web site. Another 
advantage to this is that you will be able to set up PHP and watch your PHP scripts in action before uploading your web site to a 
server that supports it. For details on setting up your web sharing account, if you have not already done so, type 
'http://127.0.0.1/~username/' into your web browser to be taken to your personal web sharing folder and to find instructions from 
Apple on how to set it up. The RAGE WebDesign manual also contains step by step instructions on setting up your personal web 
sharing and how to enable PHP on your machine. 

The last thing that you must do to allow others to see your web page by connecting to your computer and to enable PHP is to make 
sure your web site folder is in your Sites folder. RAGE WebDesign will move it there for you by pressing the 'Move to Sites Folder 
button'. In the Site Manager. Once you have personal web sharing enabled you will be able to visit 
http://127.0.0.1/~username/WebSite_Folder_Name/ in your web browser to see your web page. You can give other users the 
following address to view your web site online: http://your-ip-address/~username/WebSite_Folder_Name/. 

RAGE WebDesign can preview your web site using the Mac OS X server, if it is enabled and your web site is in your Site's folder. 
Just select this option from ‘File’ menu->’Open In...’->’Preview On Server’ or press the keyboard equivalent (COMMAND-OPTION-
R). The built in page preview feature can use Mac OS X server as well so that you can preview PHP scripts and other server side code 
in RAGE WebDesign. Just check the 'Use on Preview in RAGE WebDesign when Possible’ under the 'Web Sites' tab of the 
Preferences. When possible means that only when you have your personal web sharing enabled and your web site is in your ‘Sites’ 
folder will RAGE WebDesign preview the web page using Mac OS X's server. It is a good idea to have the 'Auto Save Document 
When Previewing' option checked under the 'Application' tab of the Preferences when using the preview on server features. 

Under the 'Web Sites' tab of the Preferences you can set 
RAGE WebDesign to use Mac OS X's built in web server 
when previewing files in RAGE WebDesign. Only if 
personal web sharing is enabled and the web page is 
located in your Sites folder will RAGE WebDesign preview 
web pages using the built in server.
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Getting Your Web Site Online 

Once you have finished creating your web pages and want to get them online, RAGE WebDesign will help you get through this 
quickly and easily. You will have to upload your web site to an FTP server. If you don't have an FTP Server you can use the one year  
of FREE web hosting that comes with RAGE WebDesign when you purchase. See the ‘One year FREE Web Hosting’ read me in the 
RAGE WebDesign folder. Your internet hosting provider may also provide free hosting for you. Call them and ask them what they 
provide. You will need to have your web site loaded in the Site Manager. Open the Site Manager from the Window menu if it is not 
already visible. When you have your FTP server information, press the ‘Settings' button and a new dialog will appear allowing you to 
enter your FTP server information. Follow these steps add your FTP information. The Settings dialog will look the window below; 

1. Enter your server address and user name or login. If 
you don’t know this information or don't have a FTP 
server, email your hosting provider or refer to the 
'One year FREE Web Hosting' read me in the RAGE 
WebDesign folder to learn about the free web hosting 
with your purchase of RAGE WebDesign. 

2. Enter the path to the directory you want to upload the 
web site to. Usually it will be your root folder of your 
HTML files which may be 'public_html/' if you have 
signed up to the free hosting that came with your 
purchase of RAGE WebDesign. If not, ask your 
hosting provider for this information. You can use the 
browse button to connect to your FTP server to locate 
the directory you want to upload to. It does not have 
to be your root folder. 

3. Next, select the type of files you want to upload from 
the Upload Filter. Usually you will want to upload all 
files including media files like pictures and movies. If 
not, select the ‘Just Web Pages’ option and select the 
type of files you want to upload. You can upload all 
web page files by selecting this option. The file types 
popup menu comes from your document types that 
you can change under the 'Edit Modes' tab in the 
Preferences. 

4. Press the ‘OK’ button in the lower right hand corner 
to save your settings.  

5. Lastly, press the ‘Upload Web Site’ button in the Site Manager. You will see a progress bar appear in front of the Site 
Manager. You will not be able to access the Site Manager until the files are done uploading. If an error occurs while 
uploading, RAGE WebDesign will attempt to reconnect unless it is an error such as incorrect login information. In which 
case, RAGE WebDesign will warn you and you can press the cancel button and start the process again while double checking 
your login details from the Settings window.  

Did you find this Quick Start Guide Helpful? Discuss any issues on our free online forums at http://www.ragesw.com/forums/ 
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